Unique Design B.V. - Email delivery delay due to SMTP-relay issue – Incident details

Email delivery delay due to SMTP-relay issue

Resolved
Operational
Started about 2 months agoLasted about 4 hours
Updates
  • Resolved
    Resolved

    We’ve just received confirmation that SMTP services are fully operational again. The queued emails are processed without any negative impact.

    Have a nice weekend!

  • Monitoring
    Monitoring

    We’re currently experiencing issues with our SMTP relay. We’re waiting on Sendgrid to release and send all queued emails.

  • Resolved
    Resolved

    We’ve just received confirmation that SMTP services are fully operational again. The queued emails are now being processed gradually over the coming hours to ensure a smooth and graceful warm-up of the SMTP service, without any negative impact.

    We’ve identified the root cause of the issue and have contacted the affected customers directly.

  • Identified
    Identified

    We’re currently experiencing issues with our SMTP relay, causing emails to be queued instead of sent immediately. Please note that no data is lost—emails in transit will still be delivered once the issue is resolved. Sendgrid is actively working on implementing the solution.